File viewing not syncing properly to Frontend

Incident Report for Levangie Laboratories

Update

We are testing the fix in staging, will be pushing to production soon.
Posted Feb 10, 2026 - 20:20 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 10, 2026 - 18:38 UTC
This incident affects: Frontend Page.